Our site www.viart.com site is operated by latest Viart Shop 5 with default Clear design
Topic Information
Webbia
Webbia
Will this latest version work with php 7.1?
 
Vito
Vito
The current latest version Viart Shop 5.0 could work with PHP 7.1 but it could produce some notices and warnings which could be disabled by appropriate PHP settings.
 
Webbia
Webbia
What are the appropriate PHP settings? Where can I find instructions on this? My web host will shut down PHP 7.0 on Monday, and I need to have the webshops functioning with 7.1 by then!
 
Webbia
Webbia
Those errors occur:
 
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /www/webvol40/2p/ymgmrcx5gfxp8zm/klinikulrikabroberg.se/public_html/includes/db_mysql.php:92 Stack trace: #0 /www/webvol40/2p/ymgmrcx5gfxp8zm/klinikulrikabroberg.se/public_html/includes/db_mysql.php(146): VA_SQL->db_connect() #1 /www/webvol40/2p/ymgmrcx5gfxp8zm/klinikulrikabroberg.se/public_html/includes/common_functions.php(3396): VA_SQL->query('SELECT setting_...') #2 /www/webvol40/2p/ymgmrcx5gfxp8zm/klinikulrikabroberg.se/public_html/includes/common.php(65): va_config() #3 /www/webvol40/2p/ymgmrcx5gfxp8zm/klinikulrikabroberg.se/public_html/index.php(18): include_once('/www/webvol40/2...') #4 {main} thrown in /www/webvol40/2p/ymgmrcx5gfxp8zm/klinikulrikabroberg.se/public_html/includes/db_mysql.php on line 92